Start import
For guidance and examples, see Import data.
# To get the unique host for an index,
# see https://docs.pinecone.io/guides/manage-data/target-an-index
PINECONE_API_KEY="YOUR_API_KEY"
INDEX_HOST="INDEX_HOST"
curl "https://$INDEX_HOST/bulk/imports" \
-H 'Api-Key: $PINECONE_API_KEY' \
-H 'Content-Type: application/json' \
-H 'X-Pinecone-Api-Version: 2026-07' \
-d '{
"integrationId": "a12b3d4c-47d2-492c-a97a-dd98c8dbefde",
"uri": "s3://BUCKET_NAME/PATH/TO/DIR",
"errorMode": {
"onError": "continue"
}
}'POST /bulk/imports
Parameters
Section titled “Parameters”X-Pinecone-Api-Version(header, string, required) — Required date-based version header
Request body
Section titled “Request body”integrationId(body, string) — The id of the storage integration that should be used to access the data.uri(body, string, required) — The URI of the bucket (or container) and import directory containing the namespaces and Parquet files you want to import. For example,s3://BUCKET_NAME/IMPORT_DIRfor Amazon S3,gs://BUCKET_NAME/IMPORT_DIRfor Google Cloud Storage, orhttps://STORAGE_ACCOUNT.blob.core.windows.net/CONTAINER_NAME/IMPORT_DIRfor Azure Blob Storage. For more information, see [Import records](https://docs.pineconerrorMode(body, object) — Indicates how to respond to errors during the import process.
Responses
Section titled “Responses”200— Successful import operation400— Bad request. The request body included invalid request parameters.401— Unauthorized. Possible causes: missing or invalid API key.4XX— An unexpected error response.5XX— An unexpected error response.