Skip to main content
Pinecone Docs

Search documentation

Type to search this documentation.

On this pageOverview

Create a collection

Serverless indexes do not support collections.

curl
PINECONE_API_KEY="YOUR_API_KEY"

curl -s "https://api.pinecone.io/collections" \
  -H "Accept: application/json" \
  -H "Content-Type: application/json" \
  -H "Api-Key: $PINECONE_API_KEY" \
  -H "X-Pinecone-Api-Version: 2026-04" \
  -d '{
        "name": "example-collection",
        "source": "docs-example"
  }'
curl
{
    "name": "example-collection",
    "status": "Initializing",
    "environment": "us-east-1-aws",
    "dimension": 1536
}

POST /collections

  • X-Pinecone-Api-Version (header, string, required) — Required date-based version header
  • name (body, string, required) — The name of the collection to be created. Resource name must be 1-45 characters long, start and end with an alphanumeric character, and consist only of lower case alphanumeric characters or '-'.
  • source (body, string, required) — The name of the index to be used as the source for the collection.
  • 201 — The collection has been successfully created.
  • 400 — Bad request. The request body included invalid request parameters.
  • 401 — Unauthorized. Possible causes: Invalid API key.
  • 402 — Payment required. Organization is on a paid plan and is delinquent on payment.
  • 403 — You've exceed your collections quota.
  • 409 — Collection of given name already exists.
  • 422 — Unprocessable entity. The request body could not be deserialized.
  • 500 — Internal server error.
Suggest an edit

Propose a replacement for this page. The site team reviews it before applying any changes.

Export
Documentation menu