Skip to main content
Pinecone Docs

Search documentation

Type to search this documentation.

On this pageOverview

Create a workspace

Create a Nexus workspace. The workspace name must be unique within the project.

Workspaces are created asynchronously. On success the workspace is returned in the Initializing state with ready set to false. Poll Describe workspace until the workspace reaches the Ready state before using it.

POST /workspaces

  • X-Pinecone-Api-Version (header, string, required) — Required date-based version header
  • name (body, string, required) — The name of the workspace. Resource name must be 1-45 characters long, start and end with an alphanumeric character, and consist only of lower case alphanumeric characters or '-'.
  • spec (body, object, required) — The spec object defines the environment in which the workspace's contexts are created. Workspaces are created in a customer-managed BYOC (Bring Your Own Cloud) environment.
  • 201 — The workspace create request has been accepted. The workspace is being provisioned asynchronously and starts in the Initializing state.
  • 400 — Bad request. The request body included invalid request parameters.
  • 401 — Unauthorized. Possible causes: Invalid API key.
  • 403 — Forbidden. The API key does not have permission to perform this action, or a project limit (such as the maximum number of workspaces) has been reached.
  • 409 — Workspace of given name already exists.
  • 422 — Unprocessable entity. The request body could not be deserialized.
  • 500 — Internal server error.
Suggest an edit

Propose a replacement for this page. The site team reviews it before applying any changes.

Export
Documentation menu