Delete a backup
PINECONE_API_KEY="YOUR_API_KEY"
BACKUP_ID="9947520e-d5a1-4418-a78d-9f464c9969da"
curl -X DELETE "https://api.pinecone.io/backups/$BACKUP_ID" \
-H "Api-Key: $PINECONE_API_KEY" \
-H "X-Pinecone-Api-Version: 2026-04"DELETE /backups/{backup_id}
curl --request DELETE \
--url https://api.pinecone.io/backups/{backup_id} \
--header 'Authorization: Bearer <token>'{
"error": {
"code": "QUOTA_EXCEEDED",
"message": "The index exceeds the project quota of 5 pods by 2 pods. Upgrade your account or change the project settings to increase the quota."
},
"status": 429
}Authorizations
Section titled “Authorizations”Authorization(header, string, required) — Bearer authentication header of the formBearer <token>.
Path Parameters
Section titled “Path Parameters”backup_id(path, string, required) — The ID of the backup to delete.
Headers
Section titled “Headers”X-Pinecone-Api-Version(header, string, required) — Required date-based version header
Response
Section titled “Response”202— The request to delete the backup has been accepted.401— Unauthorized. Possible causes: Invalid API key.404— Backup not found.412— There is a pending restore job created from this backup.500— Internal server error.