Skip to main content
Pinecone Docs

Search documentation

Type to search this documentation.

On this pageOverview

Create a backup of an index

curl
PINECONE_API_KEY="YOUR_API_KEY"
INDEX_NAME="docs-example"

curl "https://api.pinecone.io/indexes/$INDEX_NAME/backups" \
    -H "Api-Key: $PINECONE_API_KEY" \
    -H 'accept: application/json' \
    -H 'Content-Type: application/json' \
    -H "X-Pinecone-Api-Version: 2026-04" \
    -d '{
      "name": "example-backup", 
      "description": "Monthly backup of production index"
      }'
curl
{
  "backup_id":"8c85e612-ed1c-4f97-9f8c-8194e07bcf71",
  "source_index_id":"f73b36c9-faf5-4a2c-b1d6-4013d8b1cc74",
  "source_index_name":"docs-example",
  "tags":{},
  "name":"example-backup",
  "description":"Monthly backup of production index",
  "status":"Ready",
  "cloud":"aws",
  "region":"us-east-1",
  "dimension":1024,
  "record_count":96,
  "namespace_count":3,
  "size_bytes":1069169,
  "created_at":"2025-05-14T16:37:25.625540Z"
  }

POST /indexes/{index_name}/backups

  • X-Pinecone-Api-Version (header, string, required) — Required date-based version header
  • index_name (path, string, required) — Name of the index to backup
  • name (body, string) — The name of the backup.
  • description (body, string) — A description of the backup.
  • 201 — The backup has been successfully created.
  • 400 — Bad request. The request body included invalid request parameters.
  • 401 — Unauthorized. Possible causes: Invalid API key.
  • 402 — Payment required. Organization is on a paid plan and is delinquent on payment.
  • 403 — You've exceed your backup quota.
  • 422 — Unprocessable entity. The request body could not be deserialized.
  • 500 — Internal server error.
Suggest an edit

Propose a replacement for this page. The site team reviews it before applying any changes.

Export
Documentation menu